summary refs log tree commit diff
path: root/haskell/pkgs/llvm-codegen.nix
diff options
context:
space:
mode:
Diffstat (limited to 'haskell/pkgs/llvm-codegen.nix')
-rw-r--r--haskell/pkgs/llvm-codegen.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/haskell/pkgs/llvm-codegen.nix b/haskell/pkgs/llvm-codegen.nix
new file mode 100644
index 0000000..57a95c8
--- /dev/null
+++ b/haskell/pkgs/llvm-codegen.nix
@@ -0,0 +1,27 @@
+{ mkDerivation, base, bytestring, Cabal, containers, dlist
+, fetchgit, ghc-prim, hspec, hspec-hedgehog, lib, llvm-config
+, mmorph, mtl, neat-interpolation, text, text-builder-linear
+}:
+mkDerivation {
+  pname = "llvm-codegen";
+  version = "0.1.0.0";
+  src = fetchgit {
+    url = "https://github.com/luc-tielen/llvm-codegen";
+    sha256 = "0d9xj25anjznxjmpmjkgd4d8s463akvn3h61y8wq5mzab24jq2b1";
+    rev = "83b04cb576208ea74ddd62016e4fa03f0df138ac";
+    fetchSubmodules = true;
+  };
+  setupHaskellDepends = [ base Cabal containers ];
+  libraryHaskellDepends = [
+    base bytestring containers dlist ghc-prim mmorph mtl text
+    text-builder-linear
+  ];
+  libraryToolDepends = [ llvm-config ];
+  testHaskellDepends = [
+    base bytestring containers dlist ghc-prim hspec hspec-hedgehog
+    mmorph mtl neat-interpolation text text-builder-linear
+  ];
+  testToolDepends = [ llvm-config ];
+  homepage = "https://github.com/luc-tielen/llvm-codegen";
+  license = lib.licenses.bsd3;
+}